Error Dpkg Ubuntu

Ketika menginstall paket php-java-bridge di ubuntu 12.04 terjadi error dikarenakan ada file-file yang di butuhkan oleh paket tersebut tidak bisa ditemukan, sialnya malah membuat apt dan dpkg selaku software pengatur paket di ubuntu menjadi ikutan error. setiap mo update, install atau membuang sebuah paket, apt dan dpkg menjadi error karena tidak dapat menemukan dependensi (file atau paket pelengkap untuk menginstall sebuah paket) dari paket di atas tadi, padahal kita menginstall paket yang lain, kirai-kira beginilah error yang di keluarkan ubuntu.

E: The package php-java-bridge-j2ee-selinux needs to be reinstalled, but I can’t find an archive for it.

setelah googling, masuk keluar site forum-forum ubuntu akhirnya ketemu juga pada website ini dan keyword yang saya gunakan di google adalah “ubuntu E: the package need to be reinstalled, but i can’t find an archive for it” .

Hanya satu baris perintah untuk menyingkirkan error tersebut yaitu menggunakan dpkg dengan mode memaksa menghapus paket tersebut. begini perintahnya hostname@machine:~$ sudo dpkg –remove –force-remove-reinstreq nama-package contoh solusi di tempat saya

hostname@machine:~$ sudo dpkg –remove –force-remove-reinstreq php-java-bridge-j2ee-selinux

sekarang ubuntu saya kembali normal😀

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: